Messages not sending from SEDNA
Incident Report for SEDNA Systems
Postmortem

SEDNA Incident

14 Nov 2019

Summary

On November 14th, 2019 between SEDNA experienced an issue where no messages were sending for users that log in via sednanetwork.com. Some messages received a non-delivery report with undisclosed as the reason during this time. All messages that were actioned to send during this time were sent after the incident was resolved including those that received a non-delivery report.

Why this happened

This issue occurred due to a communication block between the backend workings of SEDNA and the service we use to launch features to tenants. The feature flag was not enabled correctly and in turn, the system was checking for a feature that was not enabled for users during its regular processing.

Actions and opportunities for improvement

  1. Ensure testing steps are included in the feature ticket and completed by the tester prior to deploying - ONGOING

2 Any issues with this feature should result in the mail still being sent and not stopped - IN PROGRESS

Posted Nov 19, 2019 - 12:08 UTC

Resolved
Our team have confirmed the issue of not being able to send messages has been resolved. Any messages that were pressed to send during this time will be sent, some messages received a non-delivery report however, those messages were sent to the intended recipient. If you have any questions or continue to experience issues please reach out to support@sedna.com.
Posted Nov 14, 2019 - 17:31 UTC
Monitoring
Our team have identified and deployed a fix that was affecting messages from being sent in SEDNA for users logging in via sednanetwork.com. We continue to monitor performance.
Posted Nov 14, 2019 - 17:24 UTC
Investigating
Our team are currently investigating an issue where messages are not being sent from SEDNA for users that login via sednanetwork.com. Users will see messages are not sending but can continue to use SEDNA to create messages, search and work through messages.
Posted Nov 14, 2019 - 17:13 UTC
This incident affected: SEDNA - www.sednanetwork.com.