Messages not being sent from SEDNA
Incident Report for Sedna Systems
Postmortem

19 May 2020

Summary

On May 19, 2020 at approximately ~16:15 UTC our third party SMTP email provider enforced a password reset on a subset of SEDNA sub-user accounts. This reset resulted in outbound message deliveries to fail. Once our records were updated, all sent messages were successfully sent.

Why this happened

Our third party provider alerted us via email that they were enacting this forced password reset due to a suspicion that login information had been posted online. Our IP logs show no access from an unauthorized location and there is no evidence that data in our accounts were accessed by a bad actor.

As soon as we were alerted by our monitoring systems, we began resetting the sub-user accounts and updating our records. This restored email deliverability and all queued messages were delivered.

Actions and opportunities for improvement

  1. We are working with our third party SMTP provider to ensure that should something like this happen again, we have improved notification such that we can reset the accounts ourselves - IN PROGRESS
  2. We will be adjusting our outbound Non-Delivery Receipts to include better messaging, specifically informing you that messages will be re-tried and sent via SEDNA. - NOT STARTED

For any follow up questions please reach out to support@SEDNA.com.

Posted May 21, 2020 - 18:25 BST

Resolved
We have now fully resolved this issue and any messages that were not delivered have now been re-sent. We will be conducting an internal review of the incident in the next few days and will be posting our findings on the status page for public review.

We apologies for the inconvenience and appreciate your patience while we resolved this issue.
Posted May 19, 2020 - 19:35 BST
Monitoring
We have implemented a fix and are currently monitoring the results, we will provide a final update once we can confirm the issue is fully resolved.
Posted May 19, 2020 - 19:11 BST
Identified
The team has identified the cause of this issue where messages are unable to send from SEDNA. They are currently looking into ways to resolve this.
Posted May 19, 2020 - 18:23 BST
Investigating
We are currently investigating the cause of this issue and will provide more updates as they come available.
Posted May 19, 2020 - 17:59 BST
This incident affected: SEDNA - www.sednanetwork.com.