Microsoft Incident - Users may experience delays sending and receiving email messages

Incident Report for Sedna Systems

Resolved

This incident has now been resolved
Posted Aug 29, 2025 - 17:13 BST

Update

Aug 29, 2025, 5:38 PM GMT+2
After monitoring the service and receiving confirmation from previously affected users, we’ve confirmed that impact has been remediated. The service will now resume periodic attempts to deliver emails that were sent during the impacted period.

Issue details

Issue ID: EX1144276

Affected services:
Exchange Online

Status:
Service restored

Start time: Aug 29, 2025, 12:36 PM GMT+2

End time: Aug 29, 2025, 5:10 PM GMT+2

Issue type:
Incident
Posted Aug 29, 2025 - 17:12 BST

Update

Aug 29, 2025, 4:38 PM GMT+2
The new throttling rule has successfully been deployed. We’ve received confirmation from some of the previously affected users that they can now send and receive email. Additionally, our telemetry shows that the new throttling rule is having the desired effect and providing relief.

Next update by:
Friday, August 29, 2025 at 6:00 PM GMT+2
Posted Aug 29, 2025 - 16:00 BST

Investigating

As per Microsoft:

ID: EX1144276
Issue type: Incident

Status:
Service Degradation

Impacted services:
Exchange Online

Details:
Title: Users may experience delays sending and receiving email messages

User impact:
Users may experience delays sending and receiving email messages.

Current status:
We're reviewing service monitoring telemetry to isolate the source of the issue and establish a fix.

Scope of impact:
Some users who are located in Europe attempting to send or receive Exchange Online email messages may be impacted.

Next update by: Friday, August 29, 2025, at 2:30 PM UTC
Posted Aug 29, 2025 - 14:36 BST