Unable to send or receive emails
Incident Report for SEDNA Systems
Resolved
This incident has been resolved by the developers as of 12:19AM PDT
Posted Aug 19, 2019 - 08:32 UTC
Investigating
We are currently investigating an issue where some users report are unable to send or receive messages on SEDNA.
Posted Aug 19, 2019 - 08:14 UTC
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.