Microsoft Outage

Incident Report for Sedna Systems

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 07:01 GMT

Update

We are continuing to investigate this issue.
Posted Jan 23, 2026 - 03:00 GMT

Investigating

Microsoft Outage: Degraded Service

Microsoft is currently experiencing degraded service functionality. As a result, recipients using Microsoft mailboxes may not receive emails, and messages sent from Sedna may result in NDRs.

Updates on Microsoft’s Service Health Status can be found here: https://status.cloud.microsoft/m365
Posted Jan 22, 2026 - 21:00 GMT
This incident affected: SEDNA - www.sednanetwork.com.