Users unable to login to SEDNA
Incident Report for SEDNA Systems
Postmortem

20 Apr 2021

Summary

On April 20th at approximately 16:26UTC SEDNA customers were unable to log in to a new SEDNA session. This was due to an unforeseen issue with our 3rd party authentication layer, Auth0. Customers who were currently in an active SEDNA session, and did not log out, were not impacted. At approximately 19:47UTC Auth0 had resolved the issue and SEDNA customers were able to log in to SEDNA. For customers that remained logged in, no other areas of the SEDNA platform were affected. 

Why this happened

In speaking with Auth0 on the result of the login outage, “This service disruption was due purely to performance degradation on our internal platform systems, was not the result of any third-party service, and did not result in any data leakage. After investigation, we are confident that the disruption was not caused by, and did not result in, a security compromise.”

Actions and opportunities for improvement

Internally we reviewed the Auth0 incident report and our current implementation of Auth0 as our authentication layer. Upon review of all of the information at our disposal, we have concluded that this was an isolated incident and Auth0 has taken all the necessary precautions in order to avoid this problem in the future.

Posted May 05, 2021 - 21:37 UTC

Resolved
Our 3rd party authentication provider has confirmed that they have restored services for all affected regions. Users can log in to SEDNA as expected.
Posted Apr 21, 2021 - 01:36 UTC
Update
Logging into SEDNA is working correctly now, we will continue to monitor 3rd party authentication provider. Thank you for your ongoing patience and apologies for the inconvenience.
Posted Apr 20, 2021 - 20:47 UTC
Update
We are seeing that logging in to SEDNA is now functioning correctly, we will continue to monitor the ongoing issue with our 3rd party authentication provider. Thank you for your ongoing patience.
Posted Apr 20, 2021 - 20:23 UTC
Update
We are actively monitoring the ongoing issue with our 3rd party authentication provider. We advise users not to log out of SEDNA as they will not be able to log back in. We thank you for your ongoing patience while this issue is resolved.
Posted Apr 20, 2021 - 19:11 UTC
Update
We are still actively monitoring the ongoing issue with our 3rd party authentication provider. We will continue to provide updates and thank you for the ongoing patience.
Posted Apr 20, 2021 - 18:19 UTC
Monitoring
We are actively monitoring an ongoing issue with our 3rd party authentication provider. Users are advised to avoid logging out as they will not be able to log back into SEDNA. We will continue to provide updates and thank you for the ongoing patience.
Posted Apr 20, 2021 - 17:26 UTC
Update
We are continuing to investigate this issue, If you are logged in, we encourage you to not log out of SEDNA until we report the issue is resolved.
Posted Apr 20, 2021 - 16:43 UTC
Investigating
Users that attempt to login to SEDNA are unable to login and received an error, our team is currently investigating the cause of this issue. This will only affect users that are currently not logged into an active SEDNA session.
Posted Apr 20, 2021 - 16:37 UTC
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.