Mail Ingress & Egress Outage: Customers in EU Clusters unable to Send and Receive Mail

Incident Report for Sedna Systems

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 21:30 GMT

Update

An outage affecting Sedna’s mail egress and ingress services has been identified on specific infrastructure EU clusters. Affected users are unable to send and receive mail. The issue is under investigation by engineering as an emergency.
Posted Jan 15, 2026 - 20:56 GMT

Investigating

We are currently investigating this issue.
Posted Jan 15, 2026 - 20:55 GMT
This incident affected: SEDNA - www.sednanetwork.com.