Outbound Mail Seeing Delayed Delivery Times
Incident Report for Sedna Systems
Resolved
The issue with messages being delayed on send has been resolved and outbound activity has been returned to normal levels. Thank you for your patience and we are sorry for any messages that were not delivered in a timely manner. If there are any questions please reach out to us at support@sedna.com.
Posted Apr 17, 2019 - 19:37 BST
Update
We are continuing to monitor the issue where sporadic outbound messages are being impacted by longer than usual delays. The update is slowly backfilling all requests and less than 0.01% of outbound mail is affected.

We will provide another update as soon as all mail delivery has returned to normalcy.

Please feel free to reach out to support@sedna.com with any questions.

Thanks again for your patience
Posted Apr 17, 2019 - 18:16 BST
Update
We are continuing to monitor for any further issues.
Posted Apr 17, 2019 - 18:07 BST
Monitoring
At approximately 9am PST (1600 UTC) we identified that outbound mail from SEDNA is experiencing longer than anticipated delays in reaching their destination. This is a sporadic issue and is not affecting all outbound messages.

We are currently working with our third party mail provider, SendGrid, and they are in the process of deploying a fix to resolve the delays. No SEDNA functionality is impacted and all mail is being delivered.

We will continue to provide updates as we monitor the situation and await a full resolution. Any questions can be directed to support@sedna.com.

Thank you,
Posted Apr 17, 2019 - 17:41 BST
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.