Platform Performance issues: Some customers are experiencing platform slowness

Incident Report for Sedna Systems

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 16:10 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 14:31 BST

Identified

The issue has been identified and a fix is currently being implemented. Sedna's Engineering team will continue to monitor the situation closely
Posted Jun 04, 2026 - 12:05 BST

Monitoring

We are currently investigating reports of degraded performance affecting some users on the Sedna platform. Affected users may experience slowness when navigating Sedna.

Users are still able to log in and access the platform. Our engineering team is actively investigating the root cause as a priority.

We will provide further updates as our investigation progresses. We apologise for any inconvenience caused.
Posted Jun 04, 2026 - 09:45 BST

Identified

We have identified the root cause of the issue and have implemented a fix.
Posted Jun 03, 2026 - 16:50 BST

Investigating

Platform performance issues have been identified and are affecting some Sedna customers across different clusters. Affected users may experience slowness when accessing the platform.

The issue is under investigation by engineering as an emergency.
Posted Jun 03, 2026 - 16:05 BST