Outbound Mail Delays
Incident Report for Sedna Systems
Resolved
SendGrid has confirmed the issue has been resolved. We are now marking this issue as fully resolved and our logs are showing mail deliveries have returned to normal levels. Please reach out to support@sedna.com with any questions.
Posted Jun 19, 2019 - 23:00 BST
Update
We can confirm that we are seeing a return to normal delivery times. We will continue to monitor the situation and resolve this particular incident when SendGrid has declared the issue resolved on their side.

Please reach out to support@sedna.com with any questions. Thank you for your patience.
Posted Jun 19, 2019 - 19:19 BST
Monitoring
Our third party mail delivery system, SendGrid, is currently experiencing delays in mail delivery. They have identified and implemented a fix to resolve the issue. SEDNA customers are seeing sporadic mail delays in delivery. There has been no loss of information, however, some mail is taking longer to arrive than expected.

We will continue to monitor this issue until we see our delivery times return to normal levels. We are sorry for any disruptions that this may be causing today. For further information please feel free to reach out to support@sedna.com.
Posted Jun 19, 2019 - 17:03 BST
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.