Platform performance issues: Customers experiencing autotagging slowness in Virginia1 and default clusters

Incident Report for Sedna Systems

Resolved

Dear Customer,

We're pleased to inform you that the latest update from AWS is that the issue has now been completely resolved.
https://health.aws.amazon.com/health/status

All systems are working as expected and all services should be back to full operational efficiency.

Thank you for your patience and understanding
Posted Oct 20, 2025 - 22:00 BST

Monitoring

Platform performance issues have been identified and are affecting some Sedna customers across infrastructure clusters (virginia1 and default). Affected users may see slowness and/or spinners intermittently when accessing the platform, specifically impacting auto-tagging functionality. The issue is under investigation by engineering as an emergency and is related to the AWS incident from earlier today.
Posted Oct 20, 2025 - 17:44 BST
This incident affected: SEDNA - www.sednanetwork.com.