Mail Egress Outage: Some Customers will be unable to Send Mail

Incident Report for Sedna Systems

Resolved

This incident has been resolved. Mail delivery to Microsoft 365 and Outlook recipients has returned to normal.

We saw no further reports of delayed or failed delivery following confirmation from affected customers and our monitoring.
Posted Sep 04, 2026 - 21:09 BST

Update

We are continuing to see a recovery in our services for customers sending to Microsoft and MS 365 supported recipients, and we'll continue to monitor.

We'll provide more updates as soon as they become available
Posted Sep 04, 2026 - 19:02 BST

Update

We are continuing to see a recovery in our services for customers sending to Microsoft and MS 365 supported recipients, and we'll continue to monitor.

We'll provide more updates as soon as they become available
Posted Sep 04, 2026 - 16:39 BST

Monitoring

We are seeing signs of recovery in mail delivery to Microsoft 365 and Outlook recipients, and are continuing to monitor closely to confirm the issue is fully resolved.

Microsoft has acknowledged the issue on their end, and updates from Microsoft can be tracked at: https://x.com/MSFT365Status.

We will post a further update once we've confirmed full recovery.
Posted Sep 04, 2026 - 15:58 BST

Update

We are continuing to investigate an issue affecting outbound email from Sedna to recipients hosted on Microsoft 365 and Outlook.

What's happening: Microsoft's anti-spam filtering is rejecting messages sent from a number of our outbound IP addresses. Senders are receiving bounce-back notifications (NDRs) for affected messages.

We will post updates as the investigation progresses.
Posted Sep 04, 2026 - 14:44 BST

Identified

We are investigating an issue affecting outbound email from Sedna to recipients hosted on Microsoft 365 and Outlook. Microsoft's anti-spam filtering is rejecting messages sent from a number of our outbound IP addresses, and senders are receiving bounce-back notifications (NDRs) for affected messages.

Inbound mail is not affected, and delivery to recipients outside of Microsoft 365 / Outlook is unaffected.
Posted Sep 04, 2026 - 11:50 BST

Investigating

An outage affecting Sedna’s mail egress services has been identified. Affected users are unable to send mail. The issue is under investigation by engineering as an emergency.
Posted Sep 04, 2026 - 10:36 BST
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.