Mail Ingress & Egress Outage: Some Customers in EU Clusters unable to Send and Receive Mail

Incident Report for Sedna Systems

Resolved

This incident has been resolved, and all back logged messages have been processed
Posted Feb 12, 2026 - 20:38 GMT

Monitoring

Clusters are now healthy, and the backlog is being processed, we estimate 30 minutes.
Posted Feb 12, 2026 - 20:18 GMT

Update

We are continuing to investigate this issue, and will update every hour until it is resolved.
Posted Feb 12, 2026 - 19:51 GMT

Investigating

An outage affecting Sedna’s mail egress and ingress services has been identified on specific infrastructure EU clusters. Affected users are unable to send and receive mail. The issue is under investigation by engineering as an emergency.
Posted Feb 12, 2026 - 18:48 GMT
This incident affected: SEDNA - www.sednanetwork.com.