Issue with BCC field

Incident Report for Sedna Systems

Postmortem

SEDNA Incident - BCC field

14 January 2019

Summary

On January 14, our third-party mail delivery provider, SendGrid, had an incident that affected a small subset of messages involving addresses that were in the BCC field exclusively.

Why this happened

Inadvertently, SendGrid configured a portion of SEDNA’s mail delivery to send via an “experimental pipeline.” In doing so, all messages defined as BCC only had the addresses delivered in the To field.

SendGrid corrected the configuration so all of our messages are routed through their normal production pipeline.

Actions and opportunities for improvement

We have further requested to not be included in any experimental or beta programs to avoid any disruption.

We are improving our global alert system so that issues that happen across time zones are managed efficiently.

Posted Jan 18, 2019 - 21:49 GMT

Resolved

SendGrid fixed the issue and we have verified that BCC is again working as expected.
Posted Jan 14, 2019 - 21:06 GMT

Monitoring

We have found the issue is due to SendGrid and we are working with their team to resolve this.
Posted Jan 14, 2019 - 14:16 GMT

Update

We have found a workaround that when an address is added to the 'to' field the BCC field will work as expected. When sending a mail to multiple BCC addresses, please add your team email to the To field to ensure that the BCC works as expected
Posted Jan 14, 2019 - 10:16 GMT

Investigating

We are currently investigating an issue where the BCC field is viewed by the recipient when the message is received on their end.
Posted Jan 14, 2019 - 09:56 GMT
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.