Outbound Mail Delivery: Rejections for Some Microsoft 365 / Outlook Recipients

Incident Report for Sedna Systems

Resolved

This incident has been resolved. Any messages that bounced during the incident can continue to be resent.
Posted Aug 16, 2026 - 10:00 BST

Monitoring

Some customers are experiencing SPF bounces, this is a side effect of the mitigation and not a continuation of the issue.

We are continuing to monitor closely before confirming full resolution. Any messages that bounced during the incident can continue to be resent.
Posted Aug 16, 2026 - 08:00 BST

Investigating

The anti-spam filtering issue has been mitigated. Any messages that bounced during the incident can now be resent.
Posted Aug 16, 2026 - 01:30 BST

Monitoring

The issue has been mitigated. We are monitoring closely and continuing to work with Microsoft. Any messages that bounced during the incident can now be resent.
Posted Aug 15, 2026 - 23:30 BST

Investigating

We are seeing further reports of outbound emails to Microsoft 365 and Outlook recipients being rejected. The issue is ongoing and our engineering team is continuing to work with Microsoft and our email delivery provider on a resolution.

Inbound mail remains unaffected. Bounced messages were not lost and can be resent once delivery is restored.
Posted Aug 15, 2026 - 08:30 BST

Monitoring

The issue has been mitigated. We are monitoring closely and continuing to work with Microsoft. Any messages that bounced during the incident can now be resent.
Posted Aug 15, 2026 - 01:30 BST

Investigating

We are investigating an issue affecting outbound email from Sedna to recipients hosted on Microsoft 365 and Outlook. Microsoft's anti-spam filtering is rejecting messages sent from a number of our outbound IP addresses, and senders are receiving bounce-back notifications (NDRs) for affected messages.

Inbound mail is not affected, and delivery to recipients outside of Microsoft 365 / Outlook is unaffected.

We will provide further updates as our investigation progresses.
Posted Aug 14, 2026 - 00:00 BST
This incident affected: SEDNA - www.sednanetwork.com and SEDNA - Private Hosting.