Microsoft service disruption affecting Microsoft Graph email egress

Incident Report for Sedna Systems

Update

The Microsoft service degradation is still ongoing. Microsoft has not yet provided an estimated time for resolution. We continue to monitor the situation and will provide further updates as they become available.
Posted Sep 01, 2026 - 02:28 BST

Update

We are continuing to investigate this issue.
Posted Aug 31, 2026 - 20:49 BST

Investigating

Microsoft has reported service degradation that may affect outbound emails sent from Sedna via Microsoft Graph. Customers may experience delays or failures when sending emails. We are monitoring the situation and will provide updates as they become available.
Posted Aug 31, 2026 - 20:49 BST