This incident has been resolved. Any messages that bounced during the incident can continue to be resent.
Posted Aug 18, 2026 - 19:27 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 18, 2026 - 19:00 BST
Investigating
An outage affecting Sedna’s mail egress services has been identified on our Virginia 1 clusters. Affected users are experiencing delays with sending or are unable to send mail. The issue is under investigation by engineering as an emergency.