Correct measures was put in place once delay was noted by our engineers. This has been monitored and we can confirm that service has been restored and is working as expected.
Posted Mar 18, 2026 - 13:09 GMT
Investigating
We are investigating reports of delayed mail between 10:20 am and 10:35 am GMT. We have implemented a corrective measure and are seeing normal mail delivery.
Our engineering team is actively investigating the cause. We will provide further updates as soon as more information becomes available.
Posted Mar 18, 2026 - 10:48 GMT
This incident affected: SEDNA - www.sednanetwork.com.