The backlog of emails has now been fully processed, and mail flow is functioning normally. We understand the inconvenience this may have caused and appreciate your patience as we resolved the issue.
The system was first impacted at approximately 8:30AM (GMT+1) with the system partially restored at 10:45AM (GMT+1) and all systems restored and mail delivered at 12:32 PM (GMT+1).
We appreciate your patience while we worked to resolve the issue, we will be delivered a full incident report by end of day on Monday October 20.
Posted Oct 17, 2025 - 13:32 BST
Update
Dear Customers,
Mail delivery services have now been restored, and new mail is flowing as expected. The remaining backlog is currently being processed and will be cleared shortly.
We continue to monitor performance closely to ensure full stability and update you once everything has been processed.
Thank you for your patience
Posted Oct 17, 2025 - 13:18 BST
Update
Dear Customers,
Our team continues to work on fully resolving the mail delivery issue. While new mail is flowing into the platform, there may still be intermittent issues as we complete the recovery process.
We’ve temporarily paused queued mail processing to allow our engineers to address and resolve the root cause. We’re closely monitoring the situation and will provide another update as soon as more information becomes available.
Thank you for your continued patience.
Posted Oct 17, 2025 - 12:05 BST
Update
Dear Customers,
We're currently processing the queued mail and expect the process to be completed within the next 15 mins. Once this has been completed we will confirm with an update.
Thank you once again for your continue patience
Posted Oct 17, 2025 - 11:34 BST
Update
Dear Customer
We have identified the root cause of the problem and are actively working on a resolution. New mail has been successfully flowing into the platform since approximately 10:45AM BST, and older mail is expected to be delivered shortly. We will provide the next update within 15 minutes.
Thank you for your continue patience and understanding
Posted Oct 17, 2025 - 10:56 BST
Monitoring
Dear Customers,
We have identified the root cause of the problem and are actively working on a resolution. We will provide the next update within 15 minutes. Mail sending and receiving may continue to be unavailable – other system capabilities remain unaffected.
Thank you for your continued patience
Posted Oct 17, 2025 - 10:44 BST
Identified
Dear Customers,
We’ve identified the cause of the issue affecting the mail flow. Our engineers are working on a fix and we’ll share another update once it’s resolved.
Thank you for your patience.
Posted Oct 17, 2025 - 10:19 BST
Update
Dear Customers,
Our engineering team continues to investigate the issue affecting customers who are experiencing mail flow issues
We’re working to identify the root cause and will share further updates as soon as more information becomes available.
Thank you for your continued patience.
Posted Oct 17, 2025 - 09:30 BST
Investigating
Dear Customers,
We’re aware that some customers are currently experiencing issues creating new mail and, in certain cases, receiving mail. Our engineering team is actively investigating and working to resolve the issue as quickly as possible.
We’ll continue to provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Oct 17, 2025 - 08:44 BST
This incident affected: SEDNA - www.sednanetwork.com.