Some Sedna users are experiencing delays in mail flow

Incident Report for Sedna Systems

Resolved

Any mail delayed during the outage has now been processed, and mail flow is operating normally.
Posted Aug 17, 2026 - 20:38 BST

Monitoring

All queued messages have been redriven.
Posted Aug 17, 2026 - 20:36 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 17, 2026 - 20:10 BST

Investigating

An outage affecting Sedna’s mail egress and ingress services has been identified across multiple clusters. Affected users are experiencing delays in sending and receiving mail. The issue is under investigation by our Engineering team as an emergency.
Posted Aug 17, 2026 - 19:40 BST