Mail Ingress & Egress Delay : Global

Incident Report for Sedna Systems

Resolved

Earlier today (from 11:31 to 12:09 UTC) we experienced a performance degradation of email ingress and egress globally across tenants in our public clusters. This was caused by abnormally expensive processing of a set of malformed emails sent to a large number of recipients. We will continue to monitor and investigate how our systems can be updated to improve resilience.
Posted Mar 16, 2026 - 13:16 GMT

Monitoring

System appears to be operational. Our engineering team will continue to monitor this from our end.
Posted Mar 16, 2026 - 12:41 GMT

Investigating

We are currently investigating an issue affecting mail ingress and egress globally. From 11:30 to 12:00 UTC some customers may have experienced delays or disruptions in email processing.

Our engineering team is actively investigating the cause. We will provide further updates as soon as more information becomes available.
Posted Mar 16, 2026 - 12:37 GMT
This incident affected: SEDNA - www.sednanetwork.com.