Issue Identified: Automatic Forwarding Failures in Exchange Online

Incident Report for Sedna Systems

Resolved

Final Update on Exchange Online Forwarding Issue — Issue ID: EX1072592

Microsoft has confirmed that messages users attempted to forward between 2:04 PM UTC on May 11, 2025, and 5:00 AM UTC on May 16, 2025, will not be automatically replayed.

Sedna users who wish to have emails from this period re-forwarded should contact Microsoft Support directly and reference Issue ID EX1072592. This will allow Microsoft to initiate a manual recovery of the affected messages.
Posted May 16, 2025 - 22:30 BST

Monitoring

Microsoft Exchange Online has completed the deployment of a code fix to address the underlying regression, which has resolved the issue for newly sent messages.

They are now initiating a targeted recovery process for messages affected during the impacted timeframe and are actively working on a scalable solution to ensure full remediation: Issue ID EX1072592

As a result, some previously unforwarded emails may now begin to be delivered. Sedna customers may notice the arrival of older messages - potentially up to a few days old - as part of this recovery effort.

We will continue to monitor the situation and provide updates as new information becomes available
Posted May 16, 2025 - 10:00 BST

Investigating

We are currently investigating an issue impacting automatic mail forwarding in Exchange Online: Issue ID EX1072592.

Affected users may experience delays or failures in receiving forwarded mail due to a fault within the Exchange system.

Our Engineering team is actively investigating and closely monitoring the situation. We will provide further updates as more information becomes available
Posted May 15, 2025 - 09:10 BST
This incident affected: SEDNA - www.sednanetwork.com.