Mail Creation and Delivery Issues on Dublin2 cluster

Incident Report for Sedna Systems

Resolved

Dear Customers,

Mail delivery services have now been restored, and new mail is flowing as expected.

Thank you for your patience
Posted Oct 27, 2025 - 10:41 GMT

Identified

Dear Customers,

We’re aware that some may currently be experiencing issues creating and receiving new mail. Our engineering team is actively investigating and working to resolve the issue as quickly as possible.

We’ll provide updates as the engineering team progress on resolving the issue.

Next update estimated in 15 mins
Posted Oct 27, 2025 - 10:38 GMT
This incident affected: SEDNA - www.sednanetwork.com.